Partial Microsoft Exchange outage

Incident Report for yasoon

Resolved

This incident has been resolved.
Posted Oct 01, 2020 - 12:46 CEST

Investigating

Affecting Outlook Meetings for Jira and others
---
Users can't access Exchange Online
EX223208, EX223231, EX223235
Posted Oct 01, 2020 - 09:34 CEST
This incident affected: Microsoft 365 APIs.